The marker symbol "y-[up, down, leftm right]" doesn't show up

My plotly version is 5.13.1 and it runs in jupyterlab ‘4.0.1’ in windows 10.

not sure, But I think it is kind of bug.

go.Scatter has marker option and this option has symbol types, such as

‘circle’, ‘circle-open’, ‘circle-dot’, ‘circle-open-dot’, ‘square’, ‘square-open’, …

and almost every all others are no problem to show scatters. but some options, such as “y-up”, “y-down” shows nothing.

I’ll give you example code.

import plotly.graph_objects as go

fig = go.Figure()

symbol = "circle"
new_scatter = go.Scatter(x=[1,2,3], y=[1,2,3], mode="markers", marker=dict(symbol=symbol) )
fig.add_trace(new_scatter) # no-problem

symbol = "y-up"
new_scatter = go.Scatter(x=[4,5,6], y=[4,5,6], mode="markers", marker=dict(symbol=symbol) )
fig.add_trace(new_scatter) # it doesn't show

fig.update_layout(    autosize=False,    width=500,    height=500)

hi @LaserCho We’ve been facing a few issues with jupyterlab 4. Does this bug happen in jupyterlab 3?

1 Like

I tried with “plotly.version, jupyterlab.version == (‘5.15.0’, ‘3.0.0’)”

Same. “y-up” markers show nothing, but “circle” markers show.

hi @LaserCho
You’re right. I double-checked and that y-up symbol doesn’t work. A bit strange that y-up-open works but not y-up.

Would you be willing to report this bug as a new issue?

Can you please refer to this post and the symbol attribute options when you write the issue.

1 Like

@LaserCho Thanks for creating the GitHub issue.

1 Like

Re-posting my reply to the GitHub issue:

It concerns all symbols that are not filled. They are invisible as long as marker_line_width defaults to zero. If you set

new_scatter = go.Scatter(x=[4,5,6], y=[4,5,6], mode="markers", marker=dict(symbol=symbol, line=dict(width=1)) )

they show up.