Hover info while combining mesh3d and scatter3d


I googled a lot regarding this matter, but surprisingly it does not seem to be a problem encountered by many people.

I am doing 3D plots and I have to combine volumes (mesh3d) and points (scatter3d) using R, plotly_4.8.0. It works fine, however I have trouble with the hoverinfo properties. I only want to display the hoverinfo for points from the scatter3D while ignoring the volumes.

I believe setting hoverinfo = “skip” on the mesh3d should be the way to go, but it does not work: hover info shows up as expected on points outside of the volumes, but is not triggered when hovering on top of points inside a volume. When zoomed inside a volume, the problem is reversed and points outside of the volume cannot be hovered on properly.

Anybody has an idea on how to prevent surfaces from blocking the hover events on points behind them? Any help would be appreciated, as I tried everything I could think of.

Thank you,

@Sisyphus, this seems like it could be a problem with plotly.js. Would you be able to post a reproducible example that demonstrates this?