App doesn't render (stuck at "Loading ..."; possibly React-related?)


First of all, thanks for developing such a cool software-package!
I developed a Dash-app and it worked until yesterday. I’m not sure whether I messed up something in the configuration of my desktop, but I’ve managed to reproduce the issue with a minimal example. I’ve copied the code from the first example on (simple blue/orange bar-graph) and ran it with python When I go to the specified URL, though, I see only:

Loading ....

The app does work, however, when I run the app offline (as suggested here) by adding the following lines:

app.css.config.serve_locally = True
app.scripts.config.serve_locally = True

As suggested in the aforementioned Github-issue, I’ve looked at the output of the browser’s devtools, which shows the following:

It seems that, for some reason, it cannot find the file, which indeed gives a 404 Not Found error.

Maybe the issue is something trivial from my side, in that case - apologies! I hope someone has a hint in the right direction, because I have to present my Dash-application tomorrow :grimacing:


Same issue. Very confused. What version of Chrome are you on? I updated mine yesterday, and it seems to have broken React / Dash ever since. Mac, 60.0.3112.101

Same problem since updating to the newest versions (this morning)
Seems like it hast do to with react-dom@15.4.2
It is not available on unpkg

Didn’t work on Chrome (Version 60.0.3112.101 (Official Build) (64-bit)) or Firefox (54.0 (64-bit)) on my Ubuntu 16.04 desktop.
For a quick (temporary) fix, check out this Github issue.
Simply edit the __init__ file in the dash-renderer package, replacing …

with …


Is there a workaround for apps deployed on Heroku? We won’t be able to edit the installed python dependencies there, right?

I’m not sure why the unpkg CDN is down. Until this is resolved, you can load the scripts and css locally with:

app.css.config.serve_locally = True
app.scripts.config.serve_locally = True

(FYI - The original cause of this issue (the unpkg CDN failing to serve react-dom) is being tracked here:

Hello everyone. I am a newbie on dash. I had the same problem with this. I run the hello world project on my computer on chrome and it works perfectly. But when I copy code into my VDI that has no internet connection on Ubuntu and run it offline, it didnot work on Firefox 60.0.1 although I installed all packages. It keep displaying like that and no render worked.
What is the problem and what should I do?
Thank you so much

This has not been fixed so far?