✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
📊 Dash 2.0 is Arriving. Register here.

UNPKG not being called

I’m having trouble loading my dash app (see Uncaught ReferenceError: DashRenderer is not defined) and I think I’m narrowing it down. When looking at the source html, the scripts it is trying to load differ.

The previous versions of my app that worked called the scripts from unpkg, for example:
<script src="https://unpkg.com/react@15.4.2/dist/react.min.js"></script>

However, now it seems to be calling it from dash-component-suites:
<script src="/dataplot/_dash-component-suites/dash_renderer/polyfill@7.v1_2_2m1582726833.7.0.min.js"></script>

Is there something I might have done to make it try and call the dash-component-suites instead of unpkg? I updated the dash packages recently so I wonder if there is some incompatibility thing?

Thanks for any help!

We started loading the packages locally instead of from a CDN (unpkg) by default in 1.0: https://dash.plot.ly/dash-1-0-migration

Ah I must have missed that bit.
Setting serve_locally = False seems to have worked, although not sure why it doesn’t work with locally served files.
Thanks for the link!