✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
⚡️ Concerned about the grid? Kyle Baranko teaches how to predicting peak loads using XGBoost. Register for the August webinar!

Orca not working with Xvfb on Amazon linux

I I installed orca using conda install -c plotly plotly-orca on AWS AMI, then got this error when calling plotly:
/opt/conda/envs/pysig/lib/orca_app/orca: error while loading shared libraries: libgdk_pixbuf-2.0.so.0: cannot open shared object file: No such file or directory

I read that I need to install Xvfb on the AWS AMI, along with libgtk2.0-0 and libgconf-2-4. I installed Xvfb using sudo yum install Xvfb on Amazon linux server. This installed Xvfb in /usr/bin/ but the 2 packages aren’t in AWS AMI distribution and cant be installed.

So I tried the standalone orca binary. Downloaded orca-1.3.1.AppImage to AWS AMI, Tried running the AppImage with --appimage-extract flag on and Xvfb running, no error but nothing happened.

Why is this plotly graphic library such a big hassle to run on linux headless system, esp. AWS AMI? Can someone help?

Thank you in advance.

1 Like