Plotly Orca cannot locate

I tried to install plotly-orca within Docker Container, when I tried to run orca --help I got his error
error while loading shared libraries: cannot open shared object file: No such file or directory . I am using MacOS

Installing Orca and its dependencies in a Docker image is tricky. If your objective is to be able to create images from python Plotly plots, Iโ€™d advise you to checkout the recent library kaleido that is much easier to install (just a pip install does it) than Orca.


I can only support what @RenaudLN said: do not even bother trying to get Orca running. I have tried for many hours and days. My original plan was to get it working inside an Azure Function. I ended up using Azure Container Instances. I started the Docker container they provide with all the dependencies on ACI and used it as a backend to export my plots.

Using kaleido has made this so much easier. A simple pip install kaleido is all that I need now. Donโ€™t make your life harder than it needs to be. If you have no specific reason to not use kaleido right now, you should really try it.

1 Like

Hi @RenaudLN & @finkam, thanks a lot for your response ! Iโ€™ll try to use kaleido first. Thank you so much for helping, Iโ€™ve been stucked for a while because orca haha