Multipage app deployment failed on render

Hi beloved community members
I have recently developed a dashboard for our hospital it ran successfully on the local host however when I wanted to deploy it on render it returned an error
raise exceptions.InvalidConfig(error_msg)
Mar 21 12:48:13 PM dash.exceptions.InvalidConfig: A folder called pages does not exist. If a folder for pages is not
Mar 21 12:48:13 PM required in your application, set pages_folder="". For example:
Mar 21 12:48:13 PM app = Dash(__name__, pages_folder="")
I would like to emphasize the fact that I tried all possible options looked in the documentation and stackoverflow but to no avail may you please help me
this this link to my git hub repository

with kind regards

Hi, you might try @andrew-hossack’ s tool:

I already tried to deploy it on render but I failed due to the error shown above

Hello @Bahageel88,

The pages directory is the default location for pages, you shouldn’t need to declare that to work. Just pass use_pages=True.

I recommend taking that out and trying again.

1 Like

I did it and its working perfectly on the local host the problem occurred when I tried to deploy on render please have a look at my code on Github

1 Like

I did, thats why I suggested that you do this, change this:

# set the app layout--------------------------------------------------------------------------
pages_folder=os.path.join(os.path.dirname(__name__), "pages")
app=dash.Dash(external_stylesheets=[dbc.themes.CYBORG],meta_tags=[{'name': 'viewport',
'content': 'width=device-width, initial-scale=1.0'}],suppress_callback_exceptions=True,use_pages=True,pages_folder=pages_folder)


# set the app layout--------------------------------------------------------------------------
app=dash.Dash(external_stylesheets=[dbc.themes.CYBORG],meta_tags=[{'name': 'viewport',
'content': 'width=device-width, initial-scale=1.0'}],suppress_callback_exceptions=True,use_pages=True)
1 Like

I already tried this approach and the argument use_pages=True already set the problem is that render host has trouble identifying the directory where the pages reside
Thank you very much indeed for your suggestions

Renderer should be finding the pages folder.

Have you made sure the pages folder exists there?

1 Like

Really appreciate your effort to help me
but its already there
thank you

1 Like

That is just your github repo.

I am asking you to confirm that your renderer deployment actually has the pages folder. :slight_smile:

may you explain it further for me how to confirm renderer deployment actually has the pages folder ?

I have not deployed to renderer, so I dont exactly know.

Looking at the video that @AIMPED posted above, it does seem that your repo is missing a yaml file if you went that route for deploying.

1 Like

If you follow the video you’ll see, that pages, assets and are actually stored in a src folder.

I used dash-tools to deploy this github:

BTW: are you sure you want the data to be stored on github? How does that relate to

this is not the data this is prototype
the project will be implemented in April
thank very much for your positive comment

1 Like

I tried also using src within which I put assets ,data and pages and added yaml file but didn’t work either
The same error message returned

Have you tried starting from scratch?

1 Like

You mean coding all the pages why if it’s tested and ran successfully on my local computer?

No, restart the whole deploy process.

1 Like

I followed your instructions scrupulously but no change whatsoever
Really sorry

@Bahageel88 : Tried to deploy and it worked.
You can see it here:
I copied your code and post it here: GitHub - hoatranobita/testttt

So as I said, I think you should check setting on render. Below is my settings.