🏥 🏭 Working on the COVID-19 response in Canada? Plotly & the Canadian government can help you and your organization. Learn more and get in touch.

Marker_line_width doesn't work in Scatter3d

I changing marker_line_width value. There is no effect.

x = np.arange(10)
y = np.arange(10)
z = np.arange(10)
go.Figure(go.Scatter3d(x=x, y=y, z=z, mode='markers', marker_line_width=1000))

image
version=4.5.4
using jupyter notebook

Hi @unfinity,

You have to tell plotly to draw the line and also remove marker in the line_width parameter, see below.

import numpy as np
import plotly.graph_objects as go

x = np.arange(10)
y = np.arange(10)
z = np.arange(10)
go.Figure(go.Scatter3d(x=x, y=y, z=z, mode='markers+lines', line_width=1000))

maybe don`t use `1000`as line width now ^^

Alex-

Thanks for reply! But I wanted to increase the border width of markers, that is, to make them more thicker and eye-catching. Like this:
image

As far as I checked, you can only set the line width to zero or positive non-zero. Any positive non-zero value ends up showing the same width.
Maybe it is a bug or not a feature.