Black Lives Matter. Please consider donating to Black Girls Code today.
Dash HoloViews is now available! Check out the docs.

Mapbox Error Suddenly--even Plotly's own examples broke

I made a map using plotly + mapbox in Python and it has worked for the past three months until very recently. This is the error in the console:
Error: Your custom plotly.js bundle is not using the correct mapbox-gl version
Please install mapbox-gl@0.44.1.

Even Plotly’s own examples have the same error and won’t load! https://plot.ly/python/scattermapbox/

Does anybody know how I can fix this?

There isn’t anything that you can do on your end to fix it. The problem seems to be that the correct version of mapbox is not being updated properly by the package manager and we are currently working to resolve the problem.

@vkshiro What Plotly version are you using?
I’ve just run the example above with Plotly 3.0.2 and it worked.

michaelbabyn - thanks!

empet - I now have 3.0.1 and it doesn’t change anything…but unless my understanding is wrong, I don’t see how the version I have would affect what is already online.
So the examples on this page load for you? https://plot.ly/python/scattermapbox/

I’m experiencing the same issue. If it’s a version issue, when exactly would the version be checked? During plotting? Or is the plotly code ran every time the plot is called from the plotly site to generate the plot? Because I have scattermapbox plots that I created weeks ago on my site and I haven’t touched them since but they are also not working now.

So if there isn’t anything we can do to fix it…is there anything we can do to work around it? Asking because I’m making a portfolio website and really wanted to show my map.

I am trying to do the same here and my images arent showing up since a week now. Does anyone know of a solution?

@vkshiro @Kennfucius @srb. The issue has been fixed and I have been able to view the examples posted.

The examples and my own map https://plot.ly/~VanessaVanG/0 still have the same mapbox error. But I got this response from Plotly: Thanks for your recent Plotly bug report regarding mapbox rendering. This issue has been resolved and the fix will be deployed within the next 24 hours.

So I hope it’ll work soon! :slight_smile: