Black Lives Matter. Please consider donating to Black Girls Code today.

LaTeX not functioning

Hi,

The $\delta$ or any LaTeX label does not work any more after months of perfect working.
More precisely, adding the backslash ‘’ validates the label or note text, like the ‘enter’ key.
I am on Ubuntu 15.10, with Mozilla Firefox 43.0. All plug-ins are updated. Any help ?

Thx,

Could you provide a reproducible example?

You might be onto something.

On my Ubuntu 14.04 with FF 42, https://plot.ly/~MattSundquist/2135/bessel-functions-of-the-first-kind-for-v-01234.embed should the LaTeX characters as desired but https://plot.ly/~MattSundquist/2135/bessel-functions-of-the-first-kind-for-v-01234/ does not. Can you confirm?

On Chrome 46, both links show the LaTeX characters fine.

The $\delta$ example does not work, or any other.

I confirm :
I tried your two examples: the first one shows desired characters, the second does not.
But if I try changing the names for another formula, it does not work, as expected.
So our problems seem distinct.
I’ve managed a temporary solution by the copy-paste method of LaTeX formulas.
It also work in the Ubuntu explorer (‘Navigateur’ in French).

In what environment? On plot.ly’s workspace or on the shareplot page? In your web page?

In both, and I always use the web app.

Hello,
I have a similar problem. How do you solved it?
I confirm what etienne with both expamples have had. Both work in Chrome. But in Firefox just one of them.
Please read my topic "LaTeX works only in web editor … " that I posted a few hours ago.
Do you use any other script in your main script of plotly.js you load it, maybe MathJax for another location you LaTeX need (or jquery or whatever)?

Thanks!

Yes, you’ll need to import MathJax in order to use it with plotly.js.

In order words, plotly.js does not ship with MathJax.

For more info on how to do so, go to: https://github.com/plotly/plotly.js/blob/master/dist/README.md

2 Likes

Oh yessss, it works, baby!!
Thanks a lot, etienne (très bien, etienne xD)
I had the wrong LaTeX configuration --> src="…MathJax.js?config=TeX-AMS-MML_HTMLorMML"
Infect i need "…MathJax.js?config=TeX-AMS-MML_SVG"
You saved my day! I was desperate!

Best regards…

1 Like

Hi,

Could you please be explicit about the required steps to integrate MathJax with the python package?

In the offline subpackage, on init_notebook_mode() plotly.min.js is loaded using get_plotlyjs(). How do I edit the HTML created by init_notebook_mode() to include MathJax with the correct config?

Is there a plan to include MathJax with the Python package?

Thanks,

Marco