Insecure Warnings on FireFox and Safari(not on Chrome)

every time I tried to enter the dash plotly dashboard from a web which is not developed based on Plotly. I will get a insecure message “The information you have entered on this page will be sent over an insecure connection and could be read by a third party.”

It happens on Firefox and Safari.

Is there any idea to help me avoid this insecure message?

my guess is that those dash apps aren’t being served with an SSL certificate (https vs http)

Is there any solution from my side to avoid this insecure message?
Or is there something Dash Plotly can do to fix it?

secure your dash app with https

Thanks. Is there any instructions or tutorial that can teach me how to secure my dash app?