Import _ssl : ImportError: DLL load failed:

Hi :slight_smile:

Since this morning I can’t create new Dash project, _ssl is not found when importing dash.

What’s particurly weird to me is that my old project are still working but I got the same error on my new project when I run it with the environements of previous projects.

Does someone has already encountered this problem ? Here is my prob:

1 Like

I have the same problem. I have a Python 3.7 Miniconda installation and installed Dash via pip in Anaconda Prompt. Did you solve this?


Yes but it was a long time ago and I don’t remember how… sorry

From what I remember this problem is a compatibility between ssl version previously installed on your environement and the one (I’m not even sure if there is one) installed with dash.

Maybe an upgrade of both could solve it…
Sorry I can’t help much for the moment, if i remember anything I’ll come again

No worries. Thanks for responding. I will see if I can solve it and report back if I do.

I have exactly the same problem… Did you solved it?


  • More info about my problem: Python IDE: PyCharm, Python version: 3.7

  • How I overcame this problem: create an environment with the Python version 3.6

(It is more a note to myself, as I had this problem several times :stuck_out_tongue:)

1 Like

Thanks for the update. In the meantime I have tried to install Dash==1.0.0 on a different machine, but still have the same problem. This is what makes programming so hard, not the actual coding.

I finally resolved the issue. At least for now. I’m using the Miniconda/Anaconda distribution of Python with Vusial Studio Code.

I just opened VS Code from the Anaconda Prompt (open by typing: code) after having activated the desired virtual environment.

This makes me think that it is the editor which is not smart enough know which environment is active. Even setting the correct environment in the bottom left of VS Code did still give the error. Opening from Anaconda Prompt is the only thing that worked.

I also tried Atom, which I use often as well. Had the same problem. And while googling for the solution I found many reported problems of this kind for PyCharm as well.