Black Lives Matter. Please consider donating to Black Girls Code today.

Error loading dependencies" for Dash examples in a virtual environment

I am trying to run simple examples using Dash in a virtual environment created within conda.

I can list more detailed steps to replicate this if required. The steps involved installing a new conda environment and adding the list of dash libraries in https://plot.ly/dash/getting-started#installation using pip.

I then ran the hello Dash example and got the “error loading dependencies” message.

Dash runs fine when running on the root environment however.

There is another thread that seems similar but it seems that the users are creating more involved examples whereas my error is at the very first stage of running a Dash app on a machine.

Any ideas as to what I am doing incorrect or what I can provide to solve this issue? This is a bit of a deal breaker at my company as I have to run things on virtual environments.

I wonder if this is Dash not looking in the right file paths once in the virtual environment. How do I check this?

I solved my problem.

I reinstalled Anaconda from scratch and whilst I was downloading the files I noticed
(rather embarrassingly) that I was using dash-html-components 0.9.0rc1, which is the only one that appears on my pypi search feed…

All works now using dash-html-components=0.8.0.

I shall confirm tomorrow whether dash-html-components 0.9.0rc1 was causing the problem.

glad you solved it! in the future, see https://plot.ly/dash/installation for the official, latest available versions.