Black Lives Matter. Please consider donating to Black Girls Code today.
Dash HoloViews is now available! Check out the docs.

Cannot import dash after running some button click code

I followed the installation instructions:

pip install dash==0.35.1  # The core dash backend
pip install dash-html-components==0.13.4  # HTML components
pip install dash-core-components==0.42.1  # Supercharged components
pip install dash-table==3.1.11  # Interactive DataTable component (new!)

And successfully ran some of the samples. I then tried to run the button click example and thereafter get the dreaded error: “Dash was not successfully imported. Make sure you don’t have a file named
‘dash.py’ in your current directory.”

I fully re-installed the environment and it worked for a bit. Then, I think, I ran the button click example again, and it failed again.

There are many prior references to this error message but the solutions seem to involve upgrading.
Dash seems to be a beautiful creation. I would appreciate any ideas on fixing the problem or how to debug the situation.

Addendum
import dash # this import fails
Using python 3.6 and pycharm
Tried downgrading dash to 0.30 - no change
Removed dash from venv environment and reinstalled with pip - no change

If it’s happening reliably, then you’ll need to identify exactly the steps that occurred between the working state and the non-working state.

There’s not much more than can be guessed from this information other than that it sounds like something is blocking the import of the correct Dash module. It is at all possible that the example you mentioned does somehow introduce a file named dash.py?

Thanks for the response. I carefully recreated a third test environment and could not reproduce the problem. I have not been able to find an erroneous dash.py file in the environment.
Many thanks - I may be back.