Cannot run dash-daq example loading error

I am really excited that now dash-daq is MIT licensed, and eager to try it out. However, when I try to run the following code, I got error loading dependencies.

import dash_daq as daq
import dash

app = dash.Dash()

app.layout = html.Div([   

Here are the package versions I am using:
dash == 0.36.0
dash-html-components == 0.13.5
dash-core-components == 0.43.0
dash-table ==3.1.11
dash-renderer == 0.17.0
My default browser is Chrome.
Thanks in advance.

1 Like

@chainster_mike Tried this out and indeed it’s not working!

I’ve ran across 3 issues when trying to run this from my local environment

  • Missing import dash_html_components as html (for html.Div usage)
  • I had an older version of dash-daq that was not compatible with the events change in Dash 0.36 – bumping from 0.0.6 to 0.1.0 solved that problem
  • More importantly, it seems like the dash-daq project was not published on NPM, because of that it can’t be served remotely (the default)

Let me know if you have more luck with this:

import dash_daq as daq
import dash
import dash_html_components as html

app = dash.Dash()
app.css.config.serve_locally = True
app.scripts.config.serve_locally = True

app.layout = html.Div([


Once gets fixed, you shouldn’t need the serve_locally=True flag anymore.

Thanks Marc! Your code works!

Hi Marc,

I copy-pasted your block of code to run in jupyter notebook.
However, I got error loading dependencies again.
Does this have something to do with the new version of dash?

Here are the package and versions that I am using:
dash == 0.37.0
dash-html-components == 0.13.5
dash-core-component == 0.43.1
dash-table == 3.4.0
dash-renderer == 0.18.0
My default browser is Chrome as well.

Look forward to your reply.

@almond Do you have more details as to the actual error or log entries related to the error?

@Marc-Andre the screenshot is the error log I got when running the code.
My dash_daq version is ‘0.1.2’.
Do you need any other information?

@almond I’ve tried the example code against 0.1.2 and it’s indeed not working. Updating daq to 0.1.4 seems to solve the problem (with and without serve_locally). Talking with the daq maintainer, I’m told there was an issue with the 0.1.2 build… would you mind giving this another run?

hi marc, update daq to 0.1.4 does solve the problem. thanks.