Black Lives Matter. Please consider donating to Black Girls Code today.

[solved] Plot.ly is incompatible with jQuery keyframes

Hi everyone.

I’ve been relying on plot.ly for a few months now and everything’s been just great.

Today I decided I’d get back to work on my statistics page (I’m drawing bar-gaphs, scatter-plots etc…).

After my plots were finished to load, they suddenly stopped responding. The plot is traced successfully but it does not respond to hover/click/select anymore ! :disappointed:
And the weirdest of all: the controls popped-out of their divs and went down to the bottom of the page ! :fearful: As if it was not enough, the browser gets laggy and (tried on Chrome and Firefox).

I haven’t done any development on this page for weeks now, and as far as I can remember, my page was purring like a kitten when I left it. :cat2: I’m suspecting a browser update is causing this :thinking:

What is your opinion on this ?

P.S: I am not using the CDN.

Hm… not sure what’s going on here. Can you share a link to your page?

Hey !
I am so sorry not for answering all this time… it’s just that I hadn’t a clue of what was going on. :confused:

Then I realised that I had included a new library that seems to be incompatible with Plot.ly JS. :sweat:

The library is called jQuery keyframes ! Do not include it if you intend to use plot.ly. :grin:

Problem solved, have a nice day everyone :wink: