Plotly Online Stopped Working

I’ve created a series 5 of plotly charts in my jupyter notebook. They look fine. I created a free user account because I want to link my blog to them. The first graphic worked fine. When I created the second graphic by clicking ‘edit chart’, it went through fine & I was able to link it to the blog, just like the first.

When I then moved on to the seond, third, etc., it would initially look ok, but then would suddenly revert to the second graphic. Why? I then went to the ‘My Files’ option on ploltly online. There were about 6 files I didn’t know I had created. So, I deleted them to start over. Now, when I click ‘edit graphic’ from my jupyter notebook, it won’t display and instead says ‘Not Found’. What happened? Frankly, it’s so frustrating I’m not sure it’s worth it

Do you have a piece of code to help us see where the problem may be coming from?

Did you set offline mode to work in Jupyter

>     import plotly.graph_objs as go
>     from plotly.offline import download_plotlyjs, init_notebook_mode, plot, iplot
>     init_notebook_mode(connected=True)

If you run into any issues, don’t hesitate to restart your kernel => Kernel => Restart and clear Output. This helps me to clean my code.

Hi @jess_behrens03,

When you upload the figures to chart studio with plotly.plotly.plot, make sure to specify the filename argument and give each figure that you want to share on your blog a unique file name. See for some examples of using filename.


Thanks! That worked perfectly. I should have known that was the problem, actually, but just didn’t think it through.

1 Like