Black Lives Matter. Please consider donating to Black Girls Code today.

Jupyter notebook - graphs don't display anymore

Hi !

I have used pyplot.offline to produce some graphs. They were displaying fine for weeks. And now I can’t make them display anymore.
I don’t get any error, just blank space that take the space the graph would take otherwise.

I’ve tried displaying very simple plots (the ones available in the documentations), to no effect.

Does anybody have an idea about what could be happening/ anybody faced the same problem earlier ?

thank you very much !

Well, after upgrading Pyplot to the newest version, my problem are solved. ALthough I don’t really understand why, since I was using offline mode I thought the previous version of Pyplot would have been able to work as a standalone.

Can anybody tell me why that happened ?

Hi @Bdubreu,

Glad it’s working for you now! It’s hard to say what might have been going wrong. If it happens in the future, pop open the JavaScript console for your browser and see if there are any errors (Here’s how to do it in Chrome: https://developers.google.com/web/tools/chrome-devtools/console/)

-Jon