Plotly not ploting chroropleths anymore?


I wanted to use Plotly to build an interactive world choropleth, but it seems that is it no longer working. Just as a tryout, I tested replicating the same code they have on their tutorial pages for World Choropleth Maps ( but that did not work at all (we see only the title and colorbar, no actual map is plotted).

Anybody else having the same problem or knows what is going on?

Hey @plugrafico,

Try opening the plot in an external browser (as a opposed to the default viewer).

What RStudio and Plotly version are you using? Also, what machine (i.e. Mac or Windows)?


Hy @bcd,
Thanks for the tip. When I clicked on the “Show in new window” option it opened up Chrome and there the map worked! The problem is: right after that RStudio froze and did not come back out of it!

Is there any reason why it won’t function properly on the viewer? Or for the crashing?
I am on RStudio 1.0.136, Win10, Plotly 4.7.1
Thanks again!

The tip did not help me. No maps visible. Not before updating R/R-Studio nor now when I have the latest on my Win10 Pro

platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
major 3
minor 5.0
year 2018
month 04
day 23
svn rev 74626
language R
version.string R version 3.5.0 (2018-04-23)
nickname Joy in Playing

and R-Studio Version 1.1.447 and


[1] ‘4.7.1’

And I have tried with clean environment using the code snippets at

Any help / comment would be highly appreciated

Hi @juhariis

Is this on a work or personal computer? What browser did you open up in? Were you offline at the time of running the code?

I know in Python there is a call to Plotlys world map CDN and that when my machine is offline the choropleth does not render. I am wondering if you are experiencing the same or that there are other security settings at play. Recommend trying in Chrome.

On home computer with R-Studio only. Need to check if I can knit it into html and see if opening with Chrome helps.

The html file does not show anything either. Strange. All other plotly graphs I’ve created locally work fine.

I have the same problem.

Have the same issue but this is the workaround that worked. Click on export->save as web page. The webpage now shows the map. no other option worked for me. Hope this helps!