Black Lives Matter. Please consider donating to Black Girls Code today.
Dash HoloViews is now available! Check out the docs.

Plotly not compatible with IIS

Error occurred while reading WSGI handler: Traceback (most recent call last): File “E:\IndustryDashboard\wfastcgi.py”, line 794, in main env, handler = read_wsgi_handler(response.physical_path) File “E:\IndustryDashboard\wfastcgi.py”, line 636, in read_wsgi_handler handler = get_wsgi_handler(os.getenv(“WSGI_HANDLER”)) File “E:\IndustryDashboard\wfastcgi.py”, line 603, in get_wsgi_handler handler = import(module_name, fromlist=[name_list[0][0]]) File “.\Analyst_app.py”, line 9, in plotly.tools.set_credentials_file(username=‘Indospirit’, api_key=‘xXEe2QiGUZPXMbglNZko’) File “C:\Python\Python37-32\lib\site-packages\plotly\tools.py”, line 128, in set_credentials_file raise exceptions.PlotlyError("You don’t have proper file permissions " plotly.exceptions.PlotlyError: You don’t have proper file permissions to run this function. StdOut: StdErr: C:\Python\Python37-32\lib\site-packages\plotly\tools.py:102: UserWarning: Looks like you don’t have ‘read-write’ permission to your ‘home’ (’~’) directory or to our ‘~/.plotly’ directory. That means plotly’s python api can’t setup local configuration files. No problem though! You’ll just have to sign-in using ‘plotly.plotly.sign_in()’. For help with that: ‘help(plotly.plotly.sign_in)’. Questions? Visit https://support.plot.ly

WSGI is unable to acces plotly files as required thus, the whole app falls apart.