✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
🧬 Learn how to build RNA-Seq data apps with Python & Dash. Register for the May 20 Webinar!

Plotly.io.write_image error; Orca executable not found on heroku deployment

After following the instructions on orca’s automatic error message (1. re-install orca, 2. re-set path to orca executable), the write_image function still triggers an error in my app deployment.
The function works in a local testing environment, but when the app is deployed via heroku, the path to the orca executable is not found.
I have tried all orca executables that exist on my system, and none have solved the issue.
I’m thinking this may be a requirements issue, but including plotly-orca did not solve it either.
I have followed other conversations on this forum that are related (particularly this one: Static image generation only possible with `orca`?), and none seem to have the solution.

Any advice on how to handle this error while deploying on a remote server?
Any workarounds that don’t involve orca and plotly.io.write_image would be welcome as well, although after extensive search I’ve yet to find any.

@cookbob I have the same issue. Were you able to find a workaround?