✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
🐇 Announcing Dash VTK for 3d simulation graphics. Check out the March webinar.

Plotly graph does not show up in shiny ( with example code )

Hello,

when I’m pasting the code from https://plot.ly/r/shinyapp-plotly-events/ into my console no plotly graph is diplayed, I can’t get any plot in shiny displayed with plotly.

My sessionInfo:

R version 3.4.0 (2017-04-21)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

locale:
[1] LC_COLLATE=German_Germany.1252  LC_CTYPE=German_Germany.1252    LC_MONETARY=German_Germany.1252 LC_NUMERIC=C                    LC_TIME=German_Germany.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] plotly_4.7.0       ggplot2_2.2.1.9000 feather_0.3.1      RODBC_1.3-15       dplyr_0.5.0        shiny_1.0.3       

Am I using the wrong package versions? I reinstalled everything from cran but i never see a plotly graph with shiny.
I can produce the plotly graph’s inside RStudio in the Viewer. Do I have to use any of the devtools versions of plotly/ggplot/shiny or all devtool versions? I tried plotly_4.7.0.9000 but still no output from the tables is shown.

I found a post on stackoverflow that renderPlotly({return(plot_ly(x))}) is broken, but even with renderPlotly(data) I can’t produce any frames in shiny.
https://stackoverflow.com/questions/35463404/plotly-graph-doesnt-show-up

Issue was hotfixed by https://github.com/ropensci/plotly/issues/1042 in the devtools version of plotly.