Localhost issues after Windows 10 last update

Hi there,
My apps have been working fine on my localhost, updates after updates, for almost 4 years until today.

Windows 10 updated itself 3h ago, and, for some reason, my localhost can’t be reached anymore. Neither on localhost, nor on

I tried to restore the hosts file back to its default value. (It was empty after the update). It partially fixed the issue; I’ve been able to run a dash app for a few minutes until a reboot. However, the pycharm console was full of errors concerning the dash renderer module. Problem is, I can’t reproduce it. Now, when I run the app, consols shows:

Dash is running on

  • Serving Flask app ‘’ (lazy loading)
  • Environment: production
    WARNING: This is a development server. Do not use it in a production deployment.
    Use a production WSGI server instead.
  • Debug mode: on

But the app is not available. PyCharm doesn’t even try to open the browser anymore.

I can’t display figures in my browser neither anymore (fig.show())

I’ve spent 3 hours Googling to fix this localhost issue. I can’t figure out what exactly the last update messed up with.

Did this happen to anyone else before? How to fix that?

The app, and dash, are not in cause there. It’s an issue with that dumb Windows. (Examples available in the doc doesn’t work neither)

Will update this thread if I can find a solution in the meantime.


Edit: Tried this: https://www.techwalla.com/articles/how-to-install-a-localhost-server-on-windows
but it didnt change anything.

I can ping the localhost.
But the page cant be reached.

Hi, you did see that the port number changed right? 8051 instead of 8050. Did you try that one?

Maybe there is something else on port 8050 BCS of the restart.

Maybe finding what’s active might help

You could use a restore to previous window restore point if you have one before the upgrade

And btw this techwalla link is not useful in any way, except breaking possibly more

I changed myself the port number.
After every change in config, I tried,, localhost, and the ip of my machine, on that port, and some random other port.
Again, it used to work. I don’t get what this damned last update broke.

I have the same issue no matter the port. And I rebooted the PC after each change in config. I’ve been stuck with that for 7 hours yesterday

Hi, well so most likely it will be some default security / firewall setting that has changed. I guess the easiest would be just to undo the update if you don’t want to keep troubleshooting.

In the old days you would telnet 8050 to check what was going on. Timeout usually meant nothing is listening on the port Refused would indicate firewall / security type of things.

You can check windows event log for any issues with startup of the app and/or firewall log and/or try to add a rule for tcp/8050 to allow it specifically as incoming

I tried the netstat -ano command, and a few others;
It shows:
Sent by the client, but didnt reach the server. The PyCharm console says that Dash is running on, though

After I disabled the IIS services, the browser still showed the IIS homepage when I tried to reach the This was fixed after clearing Chrome host cache chrome://net-internals/#dns

If I ping localhost, i get answers from ::1
If I ping, I get answers from

I will keep investigating.

IIS should have nothing to do with dash, also it would run on port 80.

If PyCharm says that dash is running on, then it should be reachable on that ip/port with the netstat.

I would suggest going back to basics and run an empty dash app and manually configure the options and see if you can get a three-way handshake (syn/ack/syn-ack). I think it’s its important now to distinguish between, is anything listening/running yes/no, and if so can I actually connect to it. Because now there is a lot of info without much of direction.

confirm python/dash/flask actually starts correctly, manually from the command-line without anything else.

localhost ::1 is the ipv6 stack, is ipv4. I don’t think this is a problem, but you could also try to temporarily disable ipv6 on the adapter.

I disabled entirely all the firewalls, restarted the PC, but it did not change anything.

So I re-enabled everything, and did as you suggested, start from zero.

I uninstalled Pycharm, reinstalled it, created a new project, copy-pasted some basic code from the tutorial section, ran it, and…it worked.

Glad that everything works again, but the cause of the issues will remain a mystery.

Sometimes it’s better not to ask to many questions. :slight_smile: Glad it worked out