Black Lives Matter. Please consider donating to Black Girls Code today.

Jupyterlab 2.0 support

Hi all,

Is it currently possible to run plotly widgets inside the new jupyterlab version ( When trying to install via pip I get below error message.


ValueError: This extension does not yet support the current version of JupyterLab.
Conflicting Dependencies:
JupyterLab                        Extension      Package
>=2.0.0 <2.1.0                    >=1.3.0 <2.0.0 @jupyterlab/rendermime-interfaces
See the log file for details:  /tmp/jupyterlab-debug-9jmidcc3.log
The command '/bin/sh -c /bin/bash -c "source activate main && jupyter labextension install @jupyter-widgets/jupyterlab-manager                                        && jupyter labextension install jupyterlab-plotly                                        && jupyter labextension install plotlywidget"' returned a non-zero code: 1

Thank you @bjonen for reporting this, I’ve opened so that we can take care of this.


We should have a fix out shortly :slight_smile:


Update: we have a partial fix! If you install version 1.5.3 of our extension instead of 1.5.2 it will build with JLab 2.0 and everything works except go.FigureWidget unfortunately.

We’ll have to come up with a fix for the widget… the issue tracking that is here in case anyone wants to help out!

@nicolaskruchten In the nbextensions manager UI, it is still saying incompatible. perhaps the nbextensions package manager needs the latest version of the plotly package.

For now, I am using jupyter labextension install jupyterlab-plotly on jupyter2.0.1 successfully… without the plotlywidget? maybe it’s installed as a dependency.

Maybe I should make a more general post about which plotly tools to use in jupyterlab2.0+

Yes, the jupyterlab-chart-editor is not part of and has not been upgraded to work with JupyterLab 2.0 yet.

Update: as of version 4.6.0, all of our extensions have matching version numbers with each other and the supported version of and are tested together to work on JupyterLab version 2.0 :slight_smile:

@nicolaskruchten I actually just did a fresh install of everything (jupyter lab, plotly, pandas etc) on my box and am getting the following errors:

and the log says the same thing

ValueError: The extension "@jupyterlab/plotly-extension" does not yet support the current version of JupyterLab.

Conflicting Dependencies:
JupyterLab                        Extension      Package
>=2.0.1 <2.1.0                    >=1.3.0 <2.0.0 @jupyterlab/rendermime-interfaces

Exiting application: jupyter

I used the following command to install the extension:

jupyter labextension install @jupyterlab/plotly-extension

Yes, you should not install @jupyterlab/plotly-extension … This extension is not managed by Plotly and is deprecated. You should install just the extensions listed in :slight_smile:

@nicolaskruchten ok, will give it a shot - I was confused when you mentioned trying to install 1.5.3, and then on that page you linked it’s not clear this works with jupyter lab 2.0.1 since there are no support versions listed. Hopefully someone can clean up all the old confusing stuff, thanks though!

Sorry for the confusion. We bumped the version of jupyterlab-plotly from 1.5.4 to 4.6.0 in one shot, so it would be locked to the Python version.