Black Lives Matter. Please consider donating to Black Girls Code today.

Getting started with Plotly: Widgets and JupyterLabs Conflicting Dependencies

Hello Plotly community!

While trying to get Plotly set up in JupyterLab, I’m running into an error when installing the extensions required from the instructions here:

I also found a pull request for a similar (maybe the same?) issue to add setting for Binder in ipywidgets (

Does anyone know if there’s a definitive solution to resolving the dependencies conflicts? Error code below.

# Jupyter widgets extension
jupyter labextension install @jupyter-widgets/jupyterlab-manager@1.1 --no-build

An error occured.
"@jupyter-widgets/jupyterlab-manager@1.1.0" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab                        Extension      Package
>=2.0.2 <2.1.0                    >=1.2.0 <2.0.0 @jupyterlab/application
>=4.0.2 <4.1.0                    >=3.2.0 <4.0.0 @jupyterlab/coreutils
>=2.0.2 <2.1.0                    >=1.2.0 <2.0.0 @jupyterlab/notebook
>=2.0.2 <2.1.0                    >=1.2.0 <2.0.0 @jupyterlab/rendermime
>=2.0.1 <2.1.0                    >=1.5.0 <2.0.0 @jupyterlab/rendermime-interfaces
>=5.0.2 <5.1.0                    >=4.2.0 <5.0.0 @jupyterlab/services