Jupyter Dash not working

Hi, I’m fairly new with using Plotly. I was trying to run a simple dashboard app on jupyter, using the Jupyter Dash library. However, it only works when I run the code once, and makes a error when I try to run the code again. I get the following error : ‘NoneType’ object cannot be interpreted as an integer . I’m confused on whether the error is on my end, because it works when i run the code the first time, but when I try to rerun it, i get that error. I’d appreciate any help

Ahh, nevermind, I didn’t know Dash now normally supports Dashboards in line with jupyter notebooks now! :slight_smile:

I’m running into this same issue using JupyterDash, how did you solve this?

hi @mbacvanski
Try installing dash v2.11.0. (pip install dash==2.11.0).

JupyterDash is now part of the core Dash package, so you don’t have to import JupyterDash or instantiate Dash any differentely. All the code that you see in the docs should work as is in jupyter notebooks.

An announcement about Dash 2.11 will be coming out soon.

i do have a question on this- for me, dash works perfectly in jupyter with v 2.11, but not v 2.9.2 . Is that supposed to happen?

oops, big brain fart by me, 2.11 is bigger than 2.9 :joy:

1 Like