ImportError: No module named 'dash'

I am trying to run a module named dash from the example on this link.

However, I keep receiving an error as shown:
ImportError Traceback (most recent call last)
in ()
1 import as web
----> 3 from dash.react import Dash
4 from dash.components import (div, h2, label,
5 PlotlyGraph, Dropdown)

ImportError: No module named 'dash'

What can I do to solve this problem? I am running on Jupyter and Mac OS X.

Thank you

Hi there,
Did you follow the quickstart instructions at the link where you found the example:
Specifically, it seems like you may not have run pip install --upgrade .

Hi Chelsea, I have followed the instruction from that link, including pip install --upgrade .
I run on Python 3.5 if this helps.

Thanks for specifying, it will only work with python 2.x
We likely won’t be updating that example in the near future, but I may have some other examples that could help you out depending on what you’re trying to accomplish:
a) We’ve recently added some reactive features into our javascript library so you can add dropdowns and sliders (time series) to your graphs with Plotly: //
b) This dash repo did have updated examples to work with python 3: (though as noted in the README, we’re no longer supporting these examples, and are working to develop a slightly different dash product for the future)

Hi, I am running Python 3.6 on my Jupyter notebook. I tried running the example here: and
Have installed all the required libraries, however when I run the code through command line, I get the error:
ImportError: No module named dash

Not sure what I am doing wrong, I am hoping that dash runs on Python 3.6. Need some example codes to get started

Was able to resolve this myself, sorry for the spam… thanks…

Hi, would you mind telling how you made it? I am experiencing the same problem and haven’t figured it out yet. Thanks

1 Like

Another possible solution is that the python file can only be executed from the command prompt. When you attempt to execute the file inside an IDE, you will get that error.