✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
🐇 Announcing Dash VTK for 3d simulation graphics. Check out the March webinar.

Http://127.0.0.1:8050/ not updating!

Hi all,

I’m just picking up dash, and following a program from Udemy when I’m facing a problem.

When I’m creating a new Dash application, the output in the localhost is reflecting the app.layout from a previous exercise.

The previous code should be working as intended. However, whatever I run now returns the same output in the localhost.

How am I able to force it to do a hard refresh?

Okay, not sure if it’s cheating, but restarting my computer solved the issue.
But is there any more reliable solution?

Dealing with same issue here. Windows 10

Have you tried incognito mode (to rule out browser caching)?

Is it the same with/without debug mode? What about hot reload?

Have you tried stopping the app in-between (so that you just get a page-not-found error in the browser)?

How do you run the code? Just via cmd, or through an IDE?

1 Like

I’m dealing with the same problem

Bumping this to say I have the same issue too on Windows 10, where a layout gets hard stuck. If I deploy same code to heroku I can see the change, but I have to restart computer to get it working again.

Hi @ilemi

When this happens, try checking if you have apps running in more than one console window.

A new app, or any changes, won’t show up if they are running in a second console window while the first one is still active.

Note… this might be addressing the OPs issue rather than yours. I’m not sure exactly what you mean by the layout gets hard stuck.