Heroku Error from figure_factory plotly

Hi everyone. My heroku app was working, but then I added a graph using figure_factory (for county maps), and when I check the heroku logs, I get

" File “/app/.heroku/python/lib/python3.6/site-packages/plotly/figure_factory/_county_choropleth.py”, line 620, in create_choropleth

2020-12-27T04:16:46.649113+00:00 app[web.1]: "geopandas, pyshp and shapely must be installed for this figure "

2020-12-27T04:16:46.649114+00:00 app[web.1]: ImportError: geopandas, pyshp and shapely must be installed for this figure factory.

2020-12-27T04:16:46.649115+00:00 app[web.1]:

2020-12-27T04:16:46.649115+00:00 app[web.1]: Run the following commands to install the correct versions of the following modules:

2020-12-27T04:16:46.649115+00:00 app[web.1]:

2020-12-27T04:16:46.649116+00:00 app[web.1]: ```

2020-12-27T04:16:46.649116+00:00 app[web.1]: $ pip install geopandas==0.3.0

2020-12-27T04:16:46.649116+00:00 app[web.1]: $ pip install pyshp==1.2.10

2020-12-27T04:16:46.649117+00:00 app[web.1]: $ pip install shapely==1.6.3"

However, all of these modules are in my “requirements.txt” file, so I’m not sure why I keep getting this error. I tried everything. The app works perfectly if I run it locally. Thanks!

Wow I fixed it really quickly actually. I did pip freeze >requirements.txt again and Shapely was capitalized, and it worked.

1 Like