go.Scatter connectgaps

In plotly 5.11, I use 8-trace go.Scatter plots to visualize semiconductor test results. Each trace with ~5,000 data points is from an independent test site on the same test board. Ideally, all traces would have perfect overlap.

I discovered that some clusters of data would not move as expected when using the html/scatterplot panning tool. My data was being displayed in a very inaccurate manner, had me worried a bit.

From plotly online documentation I found the option of adding ‘connectgaps=True’ to the go.Scatter parameters. My data does have gaps, so I gave this a try, and it now works perfectly

Reason for this post is the warnings I have seen about using connectgaps. No doubt this not ideal for all cases, but for mine I am so grateful this exists, never heard of it before yesterday.

In these screenshots, the green and pink clusters on the left represent the same values of data. Clearly inconsistent, connectgaps fixed this problem.

1 Like