Figure factory throws errors on chloropleth

I am trying to do the plotly example involving county level choropleths as shown here:

or here

However whether it be in pycharm on my windows system, or on my venv on my ubuntu machine right off of sublime text I am getting this error on the figure factory

Traceback (most recent call last):
File “C:/Users/Skyler/Documents/Plotly/”, line 16, in
fig = ff.create_choropleth(fips=fips, values=values)
File “C:\Users\Skyler\untitled\lib\site-packages\plotly\”, line 565, in create_choropleth
"geopandas, pyshp and shapely must be installed for this figure "
ImportError: geopandas, pyshp and shapely must be installed for this figure factory.

Run the following commands in the terminal to ensure that the correct versions of the modules are installed:
pip install geopandas==0.3.0
pip install pyshp==1.2.10
pip install shapely==1.6.3

I get this error too. Did you have any luck in solving this @Sky ?

I get the same error. Was anyone able to get it resolved?

I didn’t. I wont be able to try this till tomorrow but installing packages through anaconda might work:

I installed via conda and still did not work, despite the fact when I run “import geopandas” & “import plotly” it imports alone fine, just in the script it does not work.

Did anyone figure this out? I am getting this error message too but want to run a county chloropleth. I have confirmed that all of the necessary geopandas dependencies are installed:

from osgeo import gdal, ogr, osr
from fiona.ogrext import Iterator, ItemsIterator, KeysIterator
from geopandas import GeoDataFrame


Doesn’t throw an error. Any help would be appreciated!