Black Lives Matter. Please consider donating to Black Girls Code today.

Double-Click Unzoom not working for me at all

Hi,

I love Plot.ly!

However, double click does not work for me to unzoom a plot.

I have tried Firefox, Chrome, Edge and Opera.

This applies across all Plot.ly demo sites, including R-based ones and Python based ones and others.

It fails 100% of the time.

It also fails from the code I am developing using R using both at the distributed version and at ‘4.8.0.9000’.

Yet, it works fine for sites using other libraries including Dygraph, and also on the following test site: Browser Mouse Event Test Page

My first question is, is Double-Click Unzoom working for anybody anywhere? If so, could someone give me a link?

If it is broken everywhere, is there an open bug report? I could not find one.

Thanks

Double-click to unzoom should be operational. Note that only 2D cartesian subplots support it at the moment.

Thank you for commenting!.

However I cannot get even the most trivial example to work.

For example:


(the Hello World example at the bottom)

Could somebody possibly try it, or post a link to any example where double-click unzoom does work?

Or are you saying that it only works in subplots and not in simple plots that are not subplots?

Also my main concern is the message that pops up: “Double Click to Zoom Back Out”. This message should not come up if double-click unzoom is not going to work.

It could be something about my configuration but I cannot fathom what. I do notice that range selection by mouse drag is a little “sloppy”. Maybe that is a clue. Or maybe it is just broken for everyone. I need to somehow determine which is the case.

Thanks!

Here is a simple test case using R in which I use partial_bundle to attempt to minimize any potential interference.

p <- plot_ly(x = 1:10, y = 1:10) %>% add_markers()

p1 <- partial_bundle(p)

p1

Not at all. Graph with only cartesian axes (e.g. https://codepen.io/plotly/pen/PPVeer) should have double click working.

Thanks again.
That example also fails for me on my Windows 10 PC.

However, I figure that it must be working for you and others, so I tried it on an Android phone using the Puffin browser in trackpad mode, which provides a double click capability, and it DOES WORK there.

So I know that the basic capability is there. Why exactly it is not working on my PC, I have no idea. It is a Logitech M705 mouse. I tried various Windows mouse speed settings and they made no difference. As I mentioned, double click works ok with other JavaScript libraries and mouse click test sites.

I see that previous reports have been made of timing sensitivity in the double-click detection code. Perhaps my environment just happens to reproduce the problem nicely? If this seems plausible, I would be more than happy to gather any evidence that would be useful…

Thanks