Bring Drag & Drop to Dash with Dashboard Engine. 💫 Learn how at our next webinar!

Disabling hiden interpolation in go.Surface function

Hey there,

I’m new to the plotly community and I’m enjoying very much this library (using python).
I’m plotting 3D surface plot representing mountain ridge and snow values using go.Surface function.

fig=go.Figure(data=[go.Surface(x=(datax), y=datay, z=dataz, surfacecolor=datacolor[0], cmax=cmax, cmin=cmin, cmid=cmid, colorscale=cmap, hovertemplate ="x: %{x}"+\
"
y: %{y}"+\
"
z:%{z}"+\
"
color:%{surfacecolor}


")])

Here is the problem:
I’m assigning some snow variable to the surfacecolor argument surfacecolor=datacolor[0] but I’m seeing on the results what look like to me bilinear interpolation for surfacecolor.


Here you can see my plotly go surface (plotly makes great plots :slight_smile: )
with below a zoom on a specific mountain where you can clearly see the color interpolation

To compare here is raw data i’m feeding surfacecolor with (datacolor[0])


you can clearly see on the same mountain without interpolation
(I know my raw data are pixelated but it is my result and need it to stay that way)

My problem is to find a way to disable this interpolation and show my results data superposed to the 3D mountain.
I have looked in the documentation and didn’t find any option on an interpolation setting where clearly there is interpolation under the hood.
If you have any ideas, feel free to suggest.

Thanks

Does any one have a solution ?

Help would be appreciated :slight_smile:

@bazeiheteuppoi

There is no attribute for for go.Surface to set the interpolation type.