Black Lives Matter. Please consider donating to Black Girls Code today.

DatePicker not working

Hello!

I´m trying to use the dcc DatePickerRange and it doesnt seem to be working properly. I basically copy-pasted one of the examples:

import dash_core_components as dcc
from datetime import datetime as dt
import dash
import dash_core_components as dcc
import dash_html_components as html
import dash_renderer
from dash.dependencies import Input, Output
import plotly.offline as py

app=dash.Dash()

app.layout=html.Div(children=[
    dcc.DatePickerRange(
        end_date=dt.now(),
        display_format='MMM Do, YY',
        start_date_placeholder_text='MMM Do, YY'
    )
])

if __name__ == '__main__':
    app.run_server()

And when I open the web-app this happens:

Thanks for reporting @ber.sg! This works for me:
image

What’s happening here is that the CSS and/or JS from the unkpg CDN isn’t loading correctly. A few follow up questions:

Version: 0.13.0rc1
Yes indeed “react-dates@12.3.0” is 404.
Im not working offline but behind a corporate firewall.

Note: I updated to 0.13.0rc8 and the error still persists.

How can I solve this?

Thanks a lot!

EDIT: Its solved! I dont know If it is the fact that I used chrome, that I updated or a miracle, but today it worked with me doing nothing