Dash plotly not showing mapbox chart in Chrome


I am refering to this question. I face the same issue with Chrome Version 79.0.3945.117.

If I visit the dash plotly gallery- Oil and Gas example the map is not displayed but it is still rendered (as the legend is displayed). The same issue occurs for my own project as well.

I guess this has nothing to do with the Mapbox Token, as the charts get displayed correctly in other browsers or in chrome when I use another machine.

Any help much appreciated!

Hi @Maeaex1 I visited the Oil & gas example and had no problem with Chromium Version 79.0.3945.79 :-/. Is the Javascript console (accessed through the developer tools of your browser) printing any error message? Could you also visit one fo the mapbox pages of the plotly documentation, such as https://plot.ly/python/mapbox-layers/, and check whether the map charts are displaying correctly?

Good morning Emmanuelle,

thanks for your response and your effort to replicate my case. I checked the console and it seems the settings on chromium installed on the used machine hast WebGL not enabled.

Find attached the console output.

ok, thanks for investigating. If you want to be sure that it’s a webgl problem you can also check 3d charts (https://plot.ly/python/3d-scatter-plots/) and they should not work either. By googling “chrome enable webgl” you can find various methods to enable webgl, you probably want to specify your OS as well.

Hi Emmanuelle, thanks for your response. Seems like it is the WebGL indeed, as I can not view the 3D charts either. Unfortunately, enabling webGL in chromium doesn’t solve the problem in my case. As I am running an app on a public website I guess there is not a “general” workaround to solve this

In case you need the information, I am cross-testing my app on Windows 10 Enterprise - Version 1909, Build 18363.592

Hum the WebGL thing is really a client thing it should not depend on where you run your app. Does the error message still show in the console after you enable webGL? Just to be sure, did you try to open a new session / restart the computer (far shot, but you never know…)?