Dash Page-Load Callbacks Firing Locally But Not When Run On Server

I have a Dash app that, when run locally, runs well. Callbacks fire as they should (on page load) and the app is usable. However, when the app is deployed to a Linux server the callbacks stop working.

The server uses NGINX for URL redirection, I am not sure if this would be problematic with interfering with the callbacks, but it is worth mentioning.

The page itself loads. Everything not dependent on callbacks is functioning, so I can safely say the callbacks are not working.

Dash pages set up in a similar way on other servers have been working (behind NGINX), so I am not sure if this is a server-specific.

Is there a way to force activation of callbacks? The functionality itself seems to not be working on this server.

EDIT I have double-checked and callbacks are working, but not the page load callbacks. So the issue is that callbacks are not loading when the page loads.

EDIT 2 A different callback on page load is actually running, so the main callback I’m interested in is the only one that’s not running. Is there a verbose flag for Dash that prints all errors?


Solution was to increase the maximum entity size allowed through NGINX. This guide shows how to increase the entity size limit.

I am having the same issue. The only difference is that, i am using flask only. Is there a maximum entity object in flask? I couldn’t able to find it. Please help

1 Like