Dash apps stopped working

I’ve been working on an dash app for a while now and it turned out great. I love dash. But today everything crashed. First my app layout was totally out of order, and then it just stopped working. I tried updating to the newest version, but that doest help eather. I can’t even run the examples from the dash user guide.
This is the error message I get when I run the very first example:

File “C:\Users\ANK\AppData\Local\Continuum\anaconda3\lib\site-packages\spyder\utils\site\sitecustomize.py”, line 705, in runfile
execfile(filename, namespace)

File “C:\Users\ANK\AppData\Local\Continuum\anaconda3\lib\site-packages\spyder\utils\site\sitecustomize.py”, line 102, in execfile
exec(compile(f.read(), filename, ‘exec’), namespace)

File “C:/Users/ANK/Documents/PPC-Simulation/dashboard files/Simulationsfiles/test_dash.py”, line 16, in
html.H1(children=‘Hello Dash’),

File “C:\Users\ANK\AppData\Local\Continuum\anaconda3\lib\site-packages\dash\development\base_component.py”, line 324, in wrapper
return func(*args, **kwargs)

File “C:\Users\ANK\AppData\Local\Continuum\anaconda3\lib\site-packages\dash_html_components\H1.py”, line 61, in init
super(H1, self).init(children=children, **args)

TypeError: super(type, obj): obj must be an instance or subtype of type

Does someone know what the issue could be? Thanks

If you haven’t already, I’d suggest a fresh virtualenv and installing Dash into that. Your problem sounds like a possible mismatch in Dash package versions. A fresh install in a clean environment will give you a compatible set of packages.

I guess that was really the problem. After restarting the system everything works just fine again.

1 Like