Black Lives Matter. Please consider donating to Black Girls Code today.
Dash HoloViews is now available! Check out the docs.

Problem with Dash app (fantasy-land/map)

Hi,

I have developed an app with Plotly/Dash and have now a problem for the deployment.

The app was developed on 2 different computers and now I am trying to deploy it to a server where I will host it. During the Apache installation, I had to re-install Anaconda (my Python distribution) with the latest version. I think the app used to work on the server before the new Anaconda install but I can not tell for sure…

The app runs fine on the 2 different computers where it was developed but I have a problem on the server. The app loads ok but when I try to interact with it, it is throwing some errors in the Chrome Console (via inspect).

See below screenshot for the errors:

I am not sure how to debug this? Except trying another Python distribution maybe? Anyone has any ideas?

Please let me know if you require more information, at this point I am a bit unclear on what could be the cause for this… I guess it could be due to a new Python package? Also, the app throws the same error on Apache with mod_wsgi and with the built-in server. So this is not due to Apache.

Thanks!

So I found the issue, my machine was running different versions of 2 packages:
– dash-renderer: 0.11.3 (while the server was running 0.12.1)
– dash-core-components: 0.20.2 (server: 0.22.1)

Not sure if I could have downgraded only one package, I downgraded both and it works now. I guess I’ll have to test in the future before upgrading my packages that nothing breaks.

I had the similar issue … I downgraded dash-core-components, and it just worked

Thank you ,

This is being tracked at https://github.com/plotly/dash-core-components/issues/260.

Fix was released in dash-core-components==0.28.1