Core Components tutorial error with dropdown

When I try and run the Core Components example in: Part 2. Layout | Dash for Python Documentation | Plotly, I get the following error:

Traceback (most recent call last):
File “app.py”, line 14, in
dcc.Dropdown([‘New York City’, ‘Montréal’, ‘San Francisco’], ‘Montréal’),
File “C:\Users\AimerDev\Anaconda3\lib\site-packages\dash\development\base_component.py”, line 366, in wrapper
return func(*args, **kwargs)
File “C:\Users\AimerDev\Anaconda3\lib\site-packages\dash_core_components\Dropdown.py”, line 85, in init
super(Dropdown, self).init(**args)
File “C:\Users\AimerDev\Anaconda3\lib\site-packages\dash\development\base_component.py”, line 138, in init
raise TypeError(
TypeError: id prop must be a string or dict, not [‘New York City’, ‘Montréal’, ‘San Francisco’]

Any ideas what it doesn’t like the code copied from the tutorial?

Which dash version are you on? I believe you need Dash v2.1 to declare the dcc.Dropdown in this way.

More info in this post (highlight 2): 📣 Dash 2.1.0 Released -

Thanks - I updated to v2.1 and working fine now