Can anyone please explain this error message? TypeError: The `dash_bootstrap_components.Row` component (version 1.0.2) received an unexpected keyword argument: `no_gutters`

No matter what I try, or what I do, I receive this error message below.

I replaced the deprecated components. I moved directories. I created a separate virtual environment for the exercise. I searched all the files flagged in the Traceback for ‘gutters’, and ‘no_gutters’, but I cannot locate the source of the error.

Can anyone explain what’s happening and what I can do about it?

I would greatly appreciate it. I have uploaded the Traceback call. In addition, here are links to the complete code (one page) and, the data source used in the exercise.

Here is a link to the video.

Thank you,

Robert Pfaff

In case you can’t read the image for some reason, I pasted it too;

Traceback (most recent call last):
  File "C:\Users\rober\spindly\tryspin.py", line 28, in <module>
    dbc.Row([
  File "C:\Users\rober\spindly\venv\lib\site-packages\dash\development\base_component.py", line 425, in wrapper
    return func(*args, **kwargs)
  File "C:\Users\rober\spindly\venv\lib\site-packages\dash_bootstrap_components\_components\Row.py", line 76, in __init__
    super(Row, self).__init__(children=children, **args)
  File "C:\Users\rober\spindly\venv\lib\site-packages\dash\development\base_component.py", line 133, in __init__
    raise TypeError(
TypeError: The `dash_bootstrap_components.Row` component (version 1.0.2) received an unexpected keyword argument: `no_gutters`
Allowed arguments: align, children, className, class_name, id, justify, key, loading_state, style

Hi Robert @robertpfaff,
As we see from the error message, it’s not accepting the no_gutters keyword argument any longer. This is because Dash Bootstrap has had a major upgrade recently.

Row

Breaking Dropped no_gutters prop. Use gutter modifier classes instead. See the docs for examples.

1 Like

I hear you. In this beginner’s mind, the error message said it “received an unexpected keyword argument,” and I took its meaning literally. It led me to conclude the argument existed somewhere in the code, particularly in the files flagged in the Traceback call, which took me on a frustrating wild goose chase. Regardless, I took another route and successfully added spinners this morning by reviewing this documentation.

(Since I never added “no_gutters” to the code, it must be in their somewhere, no?)

Thank you for clarifying the issue.

2 Likes

Thanks Adam, what is the solution? I got same error when using dbc 1.1.0.

I no longer remember how I solved it, but I will gladly share the code.

It works fine, Just let me know.

Robert