App.run_server() does not display my dash table

When i run the below:

app = dash.Dash(name)

app.layout = dash_table.DataTable(
    columns=[{"name": i, "id": i} for i in data.columns],

if __name__ == '__main__':

i then get a : 'running on and then when i click on it i get a “hmm… can’t reach this page” and an error code: INET_E_RESOURCE_NOT_FOUND

app = dash.Dash(name)

should be

app = dash.Dash(__name__)

sorry i have done that and did mean that just editing wrong. still does not work.


appears to be the culprit…not sure why…might have time later to dive into it but FYI in case you weren’t going down this path…

but when i remove this it still does not work

Using the latest (aka today’s most recent update) of Dash, the following works for me:

import dash
import dash_table
import pandas as pd

df = pd.read_csv('')
app = dash.Dash(__name__)

app.layout = dash_table.DataTable(
    columns=[{"name": i, "id": i} for i in df.columns],


if __name__ == '__main__':
        # ssl_context='adhoc'

If I uncomment out the ssl_context line, it fails.

i tried that and i get:

Running on
Debugger PIN: 798-371-704

  • Serving Flask app “main” (lazy loading)
  • Environment: production
    WARNING: This is a development server. Do not use it in a production deployment.
    Use a production WSGI server instead.
  • Debug mode: on

An exception has occurred, use %tb to see the full traceback.

SystemExit: 1

If you get that error w/o running the ssl_context argument, and your environment has the most recent packages, not sure why you are getting the exception. If you are running with ssl_context, is the pyOpenSSL package installed?

i already have pyopenSsl installed… not sure why i am getting the error, could it be a windows 10 thing?

possibly…i’m running the code I provided earlier on Linux w/o issues (using latest version of Chrome). Could be browser too (maybe??)

are you running this in jupyter? if so, set debug=False as reloading is incompatible with the jupyter kernel.

1 Like

running this in jupyter notebook yes- when i set to debug=False i click on my https/ and i get the error: Error loading layout