Update_xaxes and update_yaxes do not work in the cloud

I use update_xaxes and update_yaxes to edit the x-axis and y-axis of the plots. It worked perfectly well on my computer. However, when I tried to deploy the app through PythonAnywhere, I got the following error message:

2019-08-21 22:31:01,090: Error running WSGI application
2019-08-21 22:31:01,094: TypeError: ‘NoneType’ object is not callable
2019-08-21 22:31:01,094: File “/var/www/neroli_pythonanywhere_com_wsgi.py”, line 16, in
2019-08-21 22:31:01,094: from corr import app
2019-08-21 22:31:01,095:
2019-08-21 22:31:01,095: File “/home/Neroli/mysite/corr.py”, line 88, in
2019-08-21 22:31:01,095: fig.update_yaxes(range=[-0.005, 1.005])

Wherever there is a “fig.update_yaxes” or “fig.update_xaxes”, I got the same error message. The app will work if all the “fig.update_yaxes” and"fig.update_xaxes" are deleted.

Please give me advice. Thanks in advance!

I just figured this out by myself. Adding xaxis= { ‘range’: [ -0.005, 1.005 ]}, to the layout will do.