✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
⚾️ It's finally Baseball season! Root for the home team... & Register for our Sports Analytics Webinar!

Time series plot does only extend grid, but not the graph

Hey guys

I have quite a strange problem, I hope you can help me.

I have some plots I would like to extend on a daily basis. To do so I created the plots first, and then added the "fileopt=‘extend’, just as it is demonstrated on the plotly site.

When I run the code, it does only extend the grid, but it is not updating the plot.

At first I thought I made a mistake, so I tried the same thing with some basic data, where the x-axis is not a date format, but rather consists of normal integer numbers. When I do this, it works!

Has anyone an idea how I could solve this? I guess there should be a better way to get this done than just overwrite the plot times and times again with the new data.

Thank you in advance.

Kind regards,
mesaricr

Hi, where you able to solve this? I’m trying to use the fileopt=“extend” option and the grid is updated but the coliumn name is all weird added x,y (1) … and so on.

I’m just trying to add a new row of data looks like I need to scroll the plot to view the data something to check on axis -> axis range if I manually change it I saw the new rows but I cannot update the range using this method.

I’m trying this on python but only grid data is udpated

trace0 = {
“x” : [“3/1/18”],
“y” : [40000],
}

trace1 = {
    "x" : ["3/1/18"],
    "y" : [60000],
    "text" : [80000],
}

layout = {
    "yaxis": {
    "range": [5, 17],
      }
}

data = Data( [ trace0, trace1 ] )

py.plot(data = data, layout=layout, filename =“file”, fileopt=“extend”)

Also a new grid is added how can I delete the old one?