🚀 Gen 5 of the leading AI app deployment platform launches October 6. Click for the livestream.

Sudden modulenotfounderror: 'dash' - worked yesterday not today

I am using Visual Studio Code for my application development. I ran the code yesterday and it worked without any problems. Today when I try to run the code I am getting the following error:

import dash_core_components as dcc

File “C:\Python39\lib\site-packages\dash_core_components_init_.py”, line 6, in
import dash as _dash
ModuleNotFoundError: No module named ‘dash’

The only thing I did between yesterday and today was reboot my computer. This installation has been working fine since Feburary 2021.

first startup today gave the error ModuleNotFoundError: no module named ‘dash_core_components’

I did a ‘pip install dash_core_components’ and now I get the 'no module named ‘dash’ error above
I tried ‘pip install dash’ but I am still getting the same error.

where might I begin to look for the problem? What changed?

Ok I got it working but in order to do so I had to reinstall the dash components I was using. I don’t understand what changed between yesterday and today.

I used the information in topic:

and used that pip command to install the dash components.

I am concerned that whatever happened that caused my dash components to get lost on my development PC will happen in production. Any thoughts on this?