🚀 Gen 5 of the leading AI app deployment platform launches October 6. Click for the livestream.

[SOLVED] "Error loading dependencies/layout" with app in iframe on Dash 0.37.0

Hello, I have a Dash app hosted on Python Anywhere. With an up-to-date version of Dash…

dash==0.37.0
dash-core-components==0.43.1
dash-html-components==0.13.5

the app works just fine on its designated url. But when I try to embed it in an iframe, it attempts to load for a moment then says “Error loading dependencies” or sometimes “Error loading layout”. There are no problems I can see in the network tab or in the app error logs.

However, when I use an older version of Dash…

dash==0.18.3
dash-core-components==0.13.0
dash-html-components==0.8.0
dash-renderer==0.11.0

it works in the iframe just fine. Why would the latest Dash versions prevent the app from working in an iframe? Any help is welcome, thanks in advance.

I figured out what the issue was. I noticed that everything worked in Opera, so I started tweaking Firefox settings. It was the cookie setting that was causing the issue.

If I set Firefox to block “Cookies from unvisited sites”, “All third-party cookies”, or “All cookies”, the app breaks in the iframe. But when I set it to just block “Third-party trackers”, the most permissive cookie blocking setting, then the Dash app loads in the iframe successfully.

So are the newer versions of Dash dependent on “cookies from unvisited sites”? It would be nice if it could work like the older versions did. But in any case, the issue is more or less resolved in my case.

Hi @agstanton
Thanks for the hint. I just had a frightening moment trying to implement daq and I got the “Error loading dependencies”

it seems that “dash-daq ==0.1.0” does not like to work with the following combination:

dash == 0.37.0
dash-html-components == 0.13.5
dash-core-components == 0.43.1
dash-table ==3.4.0

dash-renderer == 0.18.0