Black Lives Matter. Please consider donating to Black Girls Code today.

Server Error on County Choropleth

Hey guys,

I have a choropleth program which visualizes US counties (in Python) which was working all month but now instead of returning a plot, it returns this error message:

Traceback (most recent call last):
File “C:/Users/Patrick/Documents/GitHub/JobSkillsStatisticsWebsite/County and State Scrapers/county_scraper_companysearch.py”, line 497, in
main()
File “C:/Users/Patrick/Documents/GitHub/JobSkillsStatisticsWebsite/County and State Scrapers/county_scraper_companysearch.py”, line 38, in main
make_county_cloropleth(populated_matrix, company_name)
File “C:/Users/Patrick/Documents/GitHub/JobSkillsStatisticsWebsite/County and State Scrapers/county_scraper_companysearch.py”, line 73, in make_county_cloropleth
py.plot(fig, filename=‘choropleth_full_usa’)
File “C:\Program Files\Miniconda3\lib\site-packages\plotly\plotly\plotly.py”, line 233, in plot
response = v1.clientresp(data, **plot_options)
File “C:\Program Files\Miniconda3\lib\site-packages\plotly\api\v1\clientresp.py”, line 35, in clientresp
response = request(‘post’, url, data=payload)
File “C:\Program Files\Miniconda3\lib\site-packages\plotly\api\v1\utils.py”, line 86, in request
validate_response(response)
File “C:\Program Files\Miniconda3\lib\site-packages\plotly\api\v1\utils.py”, line 38, in validate_response
raise exceptions.PlotlyRequestError(message, status_code, content)
plotly.exceptions.PlotlyRequestError: Uh oh, an error occurred on the server.

Notes:

  • I have attempted to run previous stable builds of the same code, and none of them work. (so I can safely rule out any problems in my code).

  • I have a near identical code which plots on a state basis, which still executes and returns a graphic with no problem.

  • I’ve plotted this county choropleth in both online and offline mode, both resulting in the same error.

  • I’ve deleted all plots on my plotly account, and it doesn’t seem to have helped.

  • My username and API key are correct, (since it works with the US state choropleth), but I have also generated new API keys, without any improved results.

  • My code currently gives values to 1/3rd of the FIPS codes (US Counties), and leaves the other ones valued at 0. (If that helps anything)

  • I also tried running this under a throwaway account / API key, and got the same results. (so its probably not anything related to my specific account_

  • I can still run Plotly’s demo county choropleth (on the US unemployment rate) with no problem, (which in theory should have more calculations than mine, since 2/3rds of my FIPS codes map to 0.

  • Im also loading it into the exact same csv format as in Plotly’s demo choropleth (county), so there shouldn’t be any problems there.

I’m really confused as to why it was working fine all week, but now is not working? Is it something that Plotly has changed in their server settings, that now doesn’t allow so many points to be rendered in a single request?

I just have no idea what’s happening here… ¯_(ツ)_/¯

Thanks,
-Pat