Black Lives Matter. Please consider donating to Black Girls Code today.

Plotly.io.renderers shows default as vscode, but running in classic notebook

I tried to do some plots in classic jupyter notebook, the codes ran successfully without errors but no graphs were shown. However, if I run the notebook in vscode, the graphs will be displayed.

I check the plotly.io.renderers, it shows default as vscode even though I run it in notebook. Any idea how to get plotly.io.renderers to automatically detect correctly when I’m in notebook without specifically to define the renderer each time I want to run the codes in notebook ?

Hi @SiewLin, welcome to the forum! This sounds like a bug, thanks for reporting it. Could you please tell us

  • which environment you are using (Linux, Mac or Windows, and are you using pip or conda or something else)
  • which version of jupyter and plotly you are using?
    You can try to upgrade (pip install -U) your versions of plotly and jupyter to see if it helps…

Hi @Emmanuelle,

Thanks for your reply.

Before I try to upgrade the notebook following your proposal, I take another attempt to use a different kernel when creating a new notebook. Apparently, it is caused by the particular kernel which linked to the conda environment set up running in vscode.

By using the base kernel when creating/running in notebook, the renderer can detect correctly. So In this case, I need to be mindful of which kernel I am activating when running plotly in notebook.

Not sure if this can be integrated / corrected further directly via renderers regardless of which kernel as long as running in notebook. Thank you for your time and attention on this issue. Hope the above finding is useful.