Orca system error: orca(fig,"my_file.pdf") Error in processx::run("orca", "-h") : System command error

I tried to use the orca() function in the plotly package, but after installing the command line utility of orca using the following command:

conda create -n my_root --clone="/usr/local/anaconda3"

it says

Source: /usr/local/anaconda3
Destination: /home/trg710/.conda/envs/my_root
The following packages cannot be cloned out of the root environment:

  • conda-env-2.6.0-h36134e3_1
  • conda-4.3.27-py36h2866c0b_0
  • conda-build-3.0.23-py36h1da9bb0_0
    Packages: 232
    Files: 0

To activate this environment, use:

source activate my_root

To deactivate an active environment, use:

source deactivate

Then I enter

source /usr/local/anaconda3/bin/activate my_root
conda install -c plotly plotly-orca

Output on the screen

The following NEW packages will be INSTALLED:

plotly-orca: 1.3.1-1 plotly

Proceed ([y]/n)? y

Once it’s successfully installed, I ran the R command orca() and got the following error.

Error in processx::run(“orca”, “-h”) : System command error.

Not sure how to proceed. I couldn’t find any resolved comments on this platform. If anyone could help that’d be great.


I have the exact same issue.
I followed the conda installation approach: Orca Management | Python | Plotly
conda install -c plotly plotly-orca==1.2.1 psutil requests

The Python/Notebook scripts save the static image successfully; but R example gives error:
Error in processx::run(“orca”, “-h”) : System command error

Can anyone suggest tips to troubleshoot?