Black Lives Matter. Please consider donating to Black Girls Code today.
Dash HoloViews is now available! Check out the docs.

Multipage app Broken!

Hello Dash Community!
So… i reinstalled all my dash libraries to add the following update to my app…

but… everything just broke! even when i removed the buttons causing the trouble. I’m not getting any errors, nor and when i click on something , the console shows changes, but the app is completely unresponsive!

Any ideas on how to fix this? I anticipate that I somehow managed to install the libraries twice, or in such a way that breaks the app.

Thanks a ton!

Hi! Could you possibly share some screenshots of what’s going on, or send the source code for your app?

We made some changes recently to the dcc.Link component, see the CHANGELOG here: https://github.com/plotly/dash-core-components/blob/master/CHANGELOG.md#0241. Could you try installing the previous version, 2.4.0, and seeing if that fixes it?

pip install dash-core-components==0.24.0

I have 2 versions of the app… one with a classical multi-page format, the other using the following.

The classical one works just fine (except for the callbacks in one of the pages for some reason) when i installed 0.24.0, but the one with the show/hide option is is not…

unfortunately, I have nothing to show! the callbacks are just not being called, and sometimes, the layout just doesnt load.

I’m not getting any error messages or any funny responses in the console.

Hi Ola, sorry to hear your app is not working anymore! I’ve tried to run the example you gave us above in 0.24.1, and it works fine for me on Chrome & Firefox. What browser are you using? Could you make sure your app is running correctly, i.e. that the server is on?

I have the callbacks in separate files, could that be causing the issue (though it worked before)?

The server is up and running too…
Thanks for the response! I’ll keep you posted if i come up with any ideas :slight_smile:

Soo… here’s the issue:
I have a graph that takes data from my table, plays around with it a bit then displays, but sometimes this table is empty…

  • If i don’t address that, whenever the table is empty i get a KeyError, because none of the headers i have defined are there…
  • If i do this, the app breaks whenever the table is empty:
    def update_figure(data, value):
    try:
    #lots of code
    return figure
    except KeyError:
    pass
  • Same happens if i do this:
    def update_figure(data, value):
    if len(data!=0) :
    #lots of code
    figure = ...
    else:
    figure = {}
    return figure

Is there any other way around this?