I can't run any Dash app, even minimal examples


  • I’m running the Python script on Pycharm in a linux OS;
  • This is not the first time this is happening, when it happened before I couldn’t pip install from the Pycharm console either, what solved the problem was updating the system then restarting it;
  • The system is already up-to-date and I’ve already restarted it also;
  • This problem started randomly both times, I haven’t changed anything in the code
  • It’s not related to the if __name__ = '__main__' line, as it’s shown on the screenshot below
  • My problem is exactly the same as the last person who replied on this topic
  • I’ve also tried changing the debug mode from True to False and it didn’t changed anything
  • And I’ve also tried dealing with Pycharm itself: reloading from disk and repairing the IDE, didn’t work.

No Dash app is running, even the minimal examples, but a minimal Flask app works:

When I run the Flask app:

When I run the Dash app, I get no output whatsoever, it just gets stuck:

When I go to the localhost page, this is what happens:

Hello @Galliard,

Have you tried with a completely new virtual environment?

Actually it just as randomly started working again:

I’ll try changing the venv as you suggested next time that happens and if it doesn’t work I’ll post here again if it isn’t seem as necrobumping, thanks anyways.

Edit: But I don’t think the venv is related also, because the other project using Dash app that didn’t run had a completely different venv, not to mention that this problem started and stopped with no obvious reasons, almost randomly.